Flutter Gems is a curated list of 5600+ useful Dart & Flutter packages that are categorized based on functionality.

Discord Medium LinkedIn Twitter

git_hooks

flutter pub add git_hooks
pub.dev Source Code API Docs
Category : Developer Tools
Dart 3 compatible : Yes
Null safety : Yes
Platform(s) : Android iOS macOS Windows Linux
Dart SDK : >=2.12.0 <3.0.0
Latest Version : 1.0.1 (May, 2023)
Created : Oct, 2019
Pub Likes : 29
Pub Points : 130
GitHub Stars : 26
Open Issues : 0

About git_hooks package

Using dart to prevents bad commit or push (git hooks, pre-commit/precommit, pre-push/prepush, post-merge/postmerge and all that stuff...).It is similar to husky.

Open Source Flutter Apps & Projects that use git_hooks package

Currently, there are no open source Flutter apps available that use this package.
Please consider submitting one here.

Any issues in this page? Report here.

Last updated: February 15, 2024