Flutter Gems is a curated list of 5600+ useful Dart & Flutter packages that are categorized based on functionality.

Discord Medium LinkedIn Twitter

flutter_bloc_pattern

flutter pub add flutter_bloc_pattern
pub.dev Source Code API Docs
Category : Dependency Injection & State Management
Dart 3 compatible : Yes
Null safety : Yes
Platform(s) : Android iOS Web macOS Windows Linux
Dart SDK : >=2.14.0 <3.0.0
Flutter SDK : >=2.5.0
Latest Version : 2.3.0 (Jun, 2022)
Created : Feb, 2019
Pub Likes : 3
Pub Points : 140
GitHub Stars : 10
Open Issues : 11

About flutter_bloc_pattern package

Bloc provider. Provides bloc to descendant widget (O(1)), and the bloc is disposed appropriately by state which the bloc_provider holds internally.

Open Source Flutter Apps & Projects that use flutter_bloc_pattern package

Currently, there are no open source Flutter apps available that use this package.
Please consider submitting one here.

Any issues in this page? Report here.

Last updated: February 15, 2024