Flutter Gems is a curated list of 5600+ useful Dart & Flutter packages that are categorized based on functionality.

Discord Medium LinkedIn Twitter

elementary

by elementaryteam.dev

flutter pub add elementary
pub.dev Source Code API Docs
Category : Flutter Framework
Dart 3 compatible : Yes
Null safety : Yes
Platform(s) : Android iOS Web macOS Windows Linux
Dart SDK : >=3.0.0 <4.0.0
Flutter SDK : >=3.10.0
Latest Version : 3.0.0 (Aug, 2023)
Created : Aug, 2021
Pub Likes : 149
Pub Points : 140
GitHub Stars : 121
Open Issues : 2

About elementary package

This is architecture library with the main goal to split code between different responsibility layers, make code clear, simple, readable and easy testable.

Open Source Flutter Apps & Projects that use elementary package

Currently, there are no open source Flutter apps available that use this package.
Please consider submitting one here.

Any issues in this page? Report here.

Last updated: February 15, 2024